Let's Encrypt Certificate Issue
Incident Report for Sucuri, Inc
Resolved
This issue is resolved now and Let’s Encrypt certs are being issued. If any customers continue to have issues, please open a support ticket within your firewall dashboard.
Posted 3 months ago. Aug 01, 2019 - 17:02 UTC
Investigating
We are aware of an issue with new Let's Encrypt certificates being issued. We are investigating and will provide updates as we know more.
Posted 3 months ago. Aug 01, 2019 - 16:43 UTC
This incident affected: Sucuri Website Firewall (North America West, North America Central, North America East, North America South East, Europe West, Europe Central, Asia East, South America, Australia).