The PayPal checkout issue has been addressed. Normal functionality has been restored, and users can once again complete purchases using PayPal. We apologize for any inconvenience caused and appreciate your patience.
Posted Sep 03, 2025 - 20:02 UTC
Investigating
We are currently experiencing an issue with paypal on checkout due to changes in paypal policy we are working diligently to get an update from paypal and will release more information soon. For now we request you use a valid credit card.
Posted Sep 02, 2025 - 16:56 UTC
This incident affected: Sucuri Management Console (Website Firewall Dashboard) and Sucuri Monitoring Platform, Sucuri Remediation Platform.