Change Propagation Delays within the UI

Incident Report for Sucuri, Inc

Resolved

This incident is now resolved.
Posted Apr 03, 2026 - 01:05 UTC

Monitoring

We’ve resolved the delay in when dashboard changes take effect. You should see normal apply times now. We’re continuing to monitor and will post shortly that the issue is resolved.
Posted Apr 03, 2026 - 00:44 UTC

Investigating

We’re investigating delays in when changes made in the dashboard are applied. Saves may take longer than normal to take effect. We’ll update this incident as we learn more or when behavior is back to normal.
Posted Apr 03, 2026 - 00:22 UTC
This incident affected: Sucuri Management Console (Website Firewall Dashboard).