WAF/CDN Intermittent Network Issues – North America West

Incident Report for Sucuri, Inc

Resolved

This incident has been resolved. Thank you for your patience and understanding, if you are still having issues, please open a support ticket.
Posted Aug 28, 2025 - 14:35 UTC

Monitoring

The issue affecting the North America West region has been successfully isolated. Service performance has stabilized, and our network engineering team is actively monitoring the service to ensure continued stability. We will provide a final update once we have confirmed full resolution.
Posted Aug 27, 2025 - 14:31 UTC

Identified

Our monitoring systems have identified intermittent network disruptions affecting the North America West region, resulting in periods of degraded performance. At this time, the issue appears to be localized to this region.

The root cause has been traced to one of our upstream providers currently experiencing technical difficulties, which in turn has impacted our WAF service. The provider is actively working on remediation, and our network engineering team is closely monitoring the situation to ensure service stability.

We will continue to provide updates as more information becomes available and will confirm once services have been fully restored.

We sincerely apologize for any inconvenience this may cause and appreciate your patience as we work to resolve the matter promptly.
Posted Aug 27, 2025 - 08:48 UTC
This incident affected: Sucuri Website Firewall (North America West) and Sucuri Management Console (Website Firewall Dashboard, Monitoring Dashboard, Backups Dashboard).