Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2025 - 11:00 UTC
Scheduled
We will be performing a software upgrade on the Website Firewall Dashboard, Sucuri Support Dashboard and API servers. This will not cause any downtime for any sites but you will be unable to make any modifications on the configuration, or submit Sucuri Tickets until the maintenance is over.
Posted Mar 19, 2025 - 19:11 UTC
This scheduled maintenance affected: Sucuri Management Console (Support Dashboard, Website Firewall Dashboard) and Sucuri API Endpoints (Website Firewall API).