WAF/CDN intermittent connectivity issues

Incident Report for Sucuri, Inc

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 23:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2025 - 19:58 UTC

Investigating

Our network monitoring tools have detected some intermittent network issues impacting Cluster 7 that has resulted in degraded performance. Our network engineering team are continuing to investigate the issue and we will post further updates once we have more detailed information.

We hope to have the issue resolved shortly and we apologize for any trouble experienced.
Posted Mar 27, 2025 - 17:45 UTC
This incident affected: Sucuri Website Firewall (Europe West, Europe Central).