Degraded Performance on WAF Cluster 3

Incident Report for Sucuri, Inc

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 00:53 UTC

Monitoring

The degraded performance is over and we are monitoring the results.
Posted Sep 03, 2026 - 22:40 UTC

Update

We are continuing to investigate this issue.
Posted Sep 03, 2026 - 22:11 UTC

Investigating

We are currently experiencing degraded performance in WAF Cluster 3.

Our team has identified network instability affecting traffic routed through this location, which may result in intermittent connectivity issues, increased latency, or temporary unavailability for some customers.

We are actively investigating the issue and working to restore full stability as quickly as possible. Updates will be provided as more information becomes available.
Posted Sep 03, 2026 - 22:04 UTC
This incident affected: Sucuri Website Firewall (North America West, North America Central, North America East, North America South East).