Degraded Performance on Paris, Frankfurt, and London Regions

Incident Report for Sucuri, Inc

Update

We are still actively responding to ongoing malicious traffic impacting our infrastructure in Paris, Frankfurt, and London. Cluster 28 continues to be affected in these locations. We will share another update as soon as additional information on this incident is available.
Posted Apr 03, 2026 - 10:38 UTC

Update

We are continuing to respond to ongoing malicious traffic affecting our infrastructure in Paris, Frankfurt, and London. Cluster 28 remains impacted in these locations. We will provide an update as soon as more information about this incident becomes available.
Posted Apr 03, 2026 - 07:41 UTC

Update

We remain engaged countering sustained malicious traffic affecting our Paris, Frankfurt, and London footprint. Cluster 28 is still impacted in those locations. We will post again when we have additional information on this incident.
Posted Apr 03, 2026 - 00:26 UTC

Update

We continue to respond to sustained malicious traffic targeting our footprint in Paris, Frankfurt, and London. Cluster 28 remains affected in those locations. We’ll follow up as soon as we have further information on this incident.
Posted Apr 02, 2026 - 19:23 UTC

Update

We’re still mitigating an ongoing attack aimed at infrastructure in the Paris and Frankfurt regions. Cluster 28 is impacted in these regions at this time. We’ll post another update when we have more to share.
Posted Apr 02, 2026 - 17:57 UTC

Update

We are continuing to mitigate an ongoing attack targeting an IP in the Paris region. The region is currently stable. We will share further updates as more information becomes available.
Posted Apr 02, 2026 - 12:32 UTC

Update

The attack is still ongoing, and the affected IP is still under mitigation. The Paris region is currently stable. We will keep you informed
Posted Apr 02, 2026 - 11:23 UTC

Update

The attack is still ongoing, and the affected IP is still under mitigation. The Paris region is currently stable. We’ll provide further updates shortly.
Posted Apr 02, 2026 - 10:12 UTC

Identified

Mitigation has been applied to the IP address that was targeted by a high volume of traffic in the Paris region. The region is currently stable. We will provide further updates shortly.
Posted Apr 02, 2026 - 09:03 UTC

Investigating

We are currently working on mitigating the impact of the DDoS attack in the Paris region. Will inform about updates
Posted Apr 02, 2026 - 08:19 UTC
This incident affects: Sucuri Website Firewall (Europe West, Europe Central).