Maintenance :: US West Coast
Incident Report for Sucuri, Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Aug 14, 2017 - 22:29 UTC
Identified
We are performing routine server maintenance at one of our data centers in US (west coast). No customers and traffic will be impacted by this maintenance. We will update this message when the maintenance completes. If you have any questions, please reach out to us at : https://support.sucuri.net.
Posted over 1 year ago. Aug 14, 2017 - 17:31 UTC