Some backups dashboards unavailable.
Incident Report for Sucuri, Inc
Resolved
This issue is resolved now. If you are experiencing issues with backups, please open a ticket in your Sucuri customer dashboard.
Posted 4 months ago. May 14, 2018 - 15:03 UTC
Investigating
Sucuri SOC is aware of an incident affecting a small number of backup dashboards. We are investigating the issue now and will provide updates as new information becomes available.
Posted 4 months ago. May 14, 2018 - 13:36 UTC
This incident affected: Sucuri Backups Platform.