Monitor3 Updating
Incident Report for Sucuri, Inc
Resolved
The server is back
Posted 8 months ago. Jan 16, 2018 - 18:04 UTC
Identified
Monitor3 is currently unavailable as the patches for MeltDown/Spectre are being pushed. The process should take around 30 minutes.
Posted 8 months ago. Jan 16, 2018 - 17:37 UTC