Maintenance :: UK (London)
Incident Report for Sucuri, Inc
Resolved
Maintenance has been completed.
Posted about 1 year ago. Aug 22, 2017 - 21:39 UTC
Identified
We are performing routine server maintenance at one of our data centers in UK (London). No customers or traffic will be impacted by this maintenance. We will update this message when the maintenance completes. If you have any questions, please reach out to us at : https://support.sucuri.net.
Posted about 1 year ago. Aug 22, 2017 - 18:06 UTC